Saltar al contenido

SAP HANA XS Advanced: clona y ejecuta aplicaciones SHINE

Ahora ejecutará los módulos en un orden que satisfaga las interdependencias entre ellos. Se tomarán automáticamente antes de que se ejecuten. Si recibe un error que dice No compatible version found, utilice la última versión mencionada en el error para package.json archivo en el módulo que falla.

Por ejemplo, haga clic derecho en el user-xsjs módulo y luego haga clic en Run->Run as->Node.js Application

Si encuentra un error de construcción, haga clic en el enlace al Registros

Ejecución de módulos

Y tenga en cuenta las versiones sugeridas npm

Ejecución de módulos

Abre el package.json para este módulo y actualice las dependencias necesarias de acuerdo con el registro de errores anterior:

Ejecución de módulos

También puede obtener una pista de las dependencias que necesita ajustar haciendo clic derecho en cada módulo y seleccionando Mostrar actualizaciones de dependencia:

Ejecución de módulos

Salvar un package.json archivo con las dependencias actualizadas y ejecute el módulo.

Tan pronto āsa user-xsjs módulo en ejecución, ejecutando el core-xsjs módulo:

Ejecutando módulos

Entonces el core-node módulo:

Ejecución de módulos

Compruebe que todos los módulos se estén ejecutando. Puede verificar rápidamente porque verá una marca verde junto a cada uno de ellos:
Ejecutarlo todo

Finalmente, ejecute el módulo web. Haga clic derecho en el web->resources->launchpad->index.html y haga clic en Ejecutar como una aplicación web:

Ejecutar módulos web

Se abrirá una nueva pestaña en el navegador. Puede hacer clic en la URL generada si el proxy no permite que se inicie la aplicación.

Nota: Si recibe un error relacionado con la versión de SAP UI5, actualice la versión del recurso sapui5-provider sa mta.yaml expediente. Cambie primero al espacio de SAP con el comando xs s -t SAP y tenga en cuenta la versión basada en comandos xs mtas en la CLI para la biblioteca UI5.

Hecho

Inicie sesión para responder la pregunta